AppSuite:OX System Requirements

OX App Suite Requirements - Open-Xchange supported components overview

The following table provides an overview about the supported components of OX App Suite and further products. This overview makes no claim to be complete.

Information about Maintenance expiries of components, versions and browser support, can be found in the Maintenance Expires Table

Hardware Requirements

General Assumptions

Open-Xchange App Suite Server (middleware services) is designed to run on physical servers or virtual machines of the same flavor. Cloud environments might be used in terms of Infrastructure as a Service (IaaS), meaning that all components need to be deployed in a classical manner on virtual machines.

This means in particular, but not only:

  • Infrastructure is supposed to be "quasi-static". Automatic replacement of broken nodes is fine as long as this is always an exceptional case. Scaling out or reducing number of nodes must always be a conscious task and closely monitored.
  • The only supported "Database as a service" solution is AWS RDS for MariaDB as defined by belows compatibility table.

Especially we expect the virtual hardware to be not over-provisioned. Each VM must have dedicated resources with respect to CPU cores, RAM, IOPS, storage, network bandwidth, network latency, etc.

Network is expected to be flat, inside one datacenter, no multi-datacenter, no segments. No packet loss, low latency.

Disclaimer: All recommendations below are without guarantee and can differ for specific deployments. For mid- and large-scale setups a detailed deployment planning and sizing tests are mandatory and should be agreed on with OX Professional Services.

High Level Design / OS setup

Operate services separately (USM, Document/Image Converters) as described in Cluster Setup.

Clocks between all nodes must be synchronized (e.g. via NTP).

Open file/max process limits need to be adjusted properly. Based on the used Linux distribution and init system configuration will differ, see Resource Limits for further explanation.

Platform Architecture: 64 bit versions (x84_64) of the supported Linux distributions

Node Sizing

OX App Suite Middleware

  • Max. 8 GB heap per JVM + 4 GB system memory for other daemons and the OS (buffers, caches)
  • 4 CPU cores (virtual, physical or hyperthreads) for plain HTTP connections. If TLS is terminated on application nodes this might need to be doubled.
  • Disk space
    • 8 GB for OS and software
    • Some services like Document Converter need SWAP partitions (~1 * RAM)
    • 2 * system memory of free disk space (i.e. 12 GB RAM => 24 GB free disk space) for file spooling, log files, heap and core dumps

Untested/Unsupported Deployments

  • Changes to Garbage Collector settings
  • Running in containerized environments (Docker, rkt)
  • Elasticity/High velocity of nodes going up and down: Services are sometimes stateful and demand static configuration
  • Cloud platform services (PaaS) that promise to replacements for certain supported technologies but have not been verified by OX for these regards
  • Multi-site active-active

Software Requirements

Linux Distributions

OX App Suite is available as Linux packages for the following distributions:

Distribution Versions Remarks
     
Red Hat Enterprise Linux 7
CentOS 7 Install from RHEL package repositories
Debian 9 (Stretch), 10 (Buster)
Univention Corporate Server 4.3, 4.4
Amazon Linux 2 Install from RHEL package repositories (from App Suite v7.10.1)

Java

OX App Suite Middleware requires OpenJDK headless JRE 8 or 9. Linux distributions might offer only packages for OpenJDK 11 JRE, which is not suitable for OX App Suite. It is in those cases required to install AdoptOpenJDK 8 JRE with HotSpot VM. A comprehensive installation guide can be found at https://adoptopenjdk.net/installation.html#linux-pkg. The correct JRE package is adoptopenjdk-8-hotspot-jre.

Databases

OX App Suite uses MySQL/MariaDB with the InnoDB storage engine as its primary data store. The following vendors and products are supported.

Vendor Product Versions
     
Oracle MySQL Community Edition, Standard Edition, Enterprise Edition v5.6.x, v5.7.x
MariaDB MariaDB Server, Galera Cluster v10.1.x, v10.2.x, v10.4.x
Amazon AWS RDS for MariaDB 10.2.x (from App Suite v7.10.1)

Important Notes

  • Open-Xchange does not plan to support MySQL 8 or higher. As MariaDB and MySQL are diverging and cannot be assumed drop-in replacements anymore, Open-Xchange will focus on MariaDB Server and MariaDB Galera Cluster. Future App Suite releases > 7.10.x might rely on features only available in MariaDB.
  • Open-Xchange supports Percona XtraDB Cluster for existing customers with initial deployments done using App Suite 7.8.x or earlier. Those customers can continue to use Percona XtraDB Cluster throughout the 7.10.x release series. Like for MySQL, 7.10.x supports only versions 5.6 and 5.7. It is not planned to support Percona XtraDB Cluster beyond 7.10.x.
  • For some Linux distributions the included MySQL/MariaDB packages are too old to be used with App Suite. It is mandatory then to install a supported version from upstream package sources. Possible sources are the official vendor repositories of MySQL or MariaDB as well as for example Red Hat Software Collections.
  • Required MySQL/MariaDB configuration configuration differs between App Suite 7.8.4 and 7.10.x and also between the different database systems in terms of SQL modes. See My.cnf for details.
  • For upgrades from App Suite <= 7.8.2 to >= 7.10.0 a comprehensive database upgrade guide exists: AppSuite:7_10_Database_Migration

HTTP Reverse Proxy

An HTTP server with reverse proxy and load balancing capabilities is required in front of App Suite application servers. TLS termination, virtual hosts, path-based routing, sticky sessions and X-Forwarded headers are typical required features. OX strongly recommends Apache httpd 2.x for that. Configuration examples can be found in the quickinstall guides.

Important: For websocket support Apache httpd 2.4.x is needed, 2.2.x does not support the required ws_tunnel module. Websockets are mandatory for OX Documents starting with v7.10.3. Like with JRE and MySQL/MariaDB it might be necessary to use 3rd party packages to get the needed Linux packages. Especially for RHEL6 we recommend using Red Hat Software Collections.

Webserver

Apache httpd 2.x is required as webserver to serve static App Suite UI content. Configuration examples can be found in the quickinstall guides.

File Storage

Temporary Data

OX App Suite stores temporary files in the local file system, e.g. for spooling of uploaded data. Any file system supported by the installed JRE is suitable.

Persistent Data

Persistent data like OX Drive files, PIM attachments etc. and temporary attachment data need to be stored in a distributed file system as registered filestore that is available from all server nodes. For single-node setups a local file system mount point can be used, small to mid-scale setups can be powered by NFS. For large-scale setups object storages should be considered.

Object Storages

OX App Suite ships with different optional adapters to support object storages.

Vendor Product API Remarks
       
Amazon AWS S3 S3 HTTP API See also AppSuite:S3_File_Store
CEPH RadosGW S3 HTTP API See also AppSuite:S3_File_Store
Scality Scality RING Sproxyd HTTP API See also AppSuite:Scality_File_Store

Desktop Browser (Minimum display resolution: 1024 x 768)

Browser OX App Suite User Front-End
   
Google Chrome (latest & previous version) v7.10.3, 7.10.4
Mozilla Firefox (latest & current ESR-Version) v7.10.3, 7.10.4
Apple Safari (latest & previous version; macOS only) v7.10.3, 7.10.4
Microsoft Edge (Chromium-based & Legacy) v7.10.3, 7.10.4
Microsoft Internet Explorer 11 v7.10.3, 7.10.4
Microsoft Internet Explorer 10/11 v7.6.3

Mobile Device Support

Mobile Device Supported Browser OX App Suite User Front-End Minimum Speed Requirements
       
iPhone on iOS 13 / iOS 14 / iPad OS Safari v7.10.3, 7.10.4 3G connections (512/256kBit/s, 350ms latency)
Smartphone on Android 4.1 or later Chrome (latest & previous version) v7.10.3, 7.10.4 3G connections (512/256kBit/s, 350ms latency)

Tablet Support

Tablet Supported Browser OX App Suite User Front-End Minimum Speed Requirements
       
Apple iPad (all devices) on iOS 13 / iOS 14 / iPad OS Safari v7.10.3, 7.10.4 3G connections (512/256kBit/s, 350ms latency)
Tablets on Android 4.1 or later Chrome (latest & previous version) v7.10.3, 7.10.4 3G connections (512/256kBit/s, 350ms latency)

Calendar/Contact synchronization Apple Mac OS X

Requirement Calendar synchronization with CalDAV Contacts synchronization with CardDAV
     
macOS 10.14 (Mojave) Check.gif Check.gif
macOS 10.15 (Catalina) Check.gif Check.gif

Calendar/Contact synchronization Apple iOS

Requirement Calendar synchronization with CalDAV Contacts synchronization with CardDAV
     
Apple iOS 13 / iOS 14 / iPad OS Check.gif Check.gif

Mobility Solution - Supported- Platforms, Features and Devices

Feature/Technology/Device OXtender for Business Mobility (availalble for App Suite, OXHE, OXSE)
   
Exchange Active Sync 2.5 Check.gif
Exchange Active Sync 12.1 Check.gif
   
Access and creation of emails Check.gif
Personal PIM folder Check.gif
Public and Shared PIM folder Cross.gif
Global address book Check.gif
Push E-Mail Check.gif
   
Apple iOS 13 / iOS 14 / iPad OS Check.gif
Android 8 (Oreo) or later with latest Gmail app. Check.gif

OX Drive for Clients

Requirement System / Platform
   
OX App Suite OX App Suite v7.10.3, 7.10.4
OX Drive for Windows Latest versions of Windows 8, latest versions of Windows 10 (no support of Mac OS X clients with emulators and Windows RT)
OX Drive for Mac OS macOS 10.14 (Mojave), macOS 10.15 (Catalina)
OX Drive for iOS Apple iOS 13 / iOS 14 / iPad OS
OX Drive for Android Smartphone on Android 5.x or later with Chrome (latest & previous version), Tablets on Android 5.x or later with Chrome (latest & previous version)

OX Sync App

Requirement System / Platform / User Interface
   
OX App Suite OX App Suite v7.10.3, 7.10.4
OX Sync App for Android Smartphone on Android 4.0 or later

OX Guard

Requirement System / Platform / User Interface
   
OX App Suite OX Guard since v2.10.3: OX App Suite v7.10.3, OX Guard since v2.10.4: OX App Suite v7.10.4
Mobile Device and Tablet Support Apple iPhone on iOS 13 / iOS 14 / iPad OS: Safari (latest version & previous version)
Smartphone on Android 4.1 or later: Chrome (latest & previous version)
Apple iPad (all devices) on iOS 13 / iOS 14 / iPad OS: Safari Safari (latest version & previous version)
Tablets on Android 4.1 or later: Chrome (latest & previous version)