CalDAV access via Thunderbird/Lightning

This article describes how the Open-Xchange server can be accessed via its CalDAV interface using the Mozilla Thunderbird client with the Lightning Add-on.

Prerequisites

Please ensure that the following preconditions are met before continuing:


Discover the CalDAV URL of your Calendar Folders

In contrast to some other clients, Thunderbird/Lightning is not able to discover all the available calendar collections automatically. Instead, each calendar folder needs to be added seperately in the client. To do so, one needs to know the CalDAV URLs of the calendar folder that should be synchronized with the client. This URL is displayed in the properties-page in the Groupware web-interface.

CalDAV URL Step1.png
  • Open a webbrowser and login to the groupware web-interface
  • From the folder tree, open the context menu of a calendar folder and select "Properties"
CalDAV URL Step2.png
  • The CalDAV URL is shown in the content area. Note down the URL or copy it to the clipboard.

Add a Calendar in Thunderbird/Lightning

As already mentioned, each Calendar folder that should be sychronized has to be added separately in the client. The following steps show how to add a Calendar in Thunderbird/Lightning. Before starting, ensure that the client is connected to the network and the server can be accessed.

LightningSetup Step1.png
  • Select "Events and Tasks" -> "Calendar" from the menu bar to switch to the Calendar view
LightningSetup Step2.png
  • From the menu bar, select "File" -> "New" -> "Calendar..."
LightningSetup Step3.png
  • In the popup window, select "On the network" and click "Next >"
LightningSetup Step4.png
  • As format, select "CalDAV"
  • Enter the CalDAV path as reported by the folder's properties page (see above) as location
  • For offline access, check the "Cache" checkbox
  • Click "Next >" to continue
LightningSetup Step5.png
  • Enter a name for the Calendar and assign a color if you like
  • Select whether reminders should be shown or not
  • Select the E-Mail account belonging to the Calendar user from the list
  • Click "Next >" to create the Calendar
LightningSetup Step6.png
  • When requested, enter your username and password for the server
  • Afterwards, the Calendar setup is complete and the contents are synchronized

Limitations

Please consider the following known limitations when synchronizing your calendar folders via Thunderbird/Lightning:

Reminders

  • While the iCalendar standard allows to set appointment reminders past due an appointment's start-date, the OX server is not able to save such alarm times and discards them.
  • Multiple reminders in an event are not supported by the OX server and are discarded.
  • Only reminders of type "DISPLAY" are supported by the OX server, reminders of other iCal types are discarded.
  • When dismissing reminders of recurring appointments in the Mozilla Lightning client, the reminder is removed from the whole recurring appointment object, since it's not possible to determine to which occurrence the dismiss action belongs to.

Unsupported Properties

  • The "URL" property for iCal resources is not supported by the OX server and is discarded.
  • Importing or exporting file attachments (property "ATTACH") is not supported via the CalDAV interface

Private Appointments

  • Appointments classified as "private" are exported by the server with the "CLASS" property set to "PRIVATE"
  • iCal events with the "CLASS" property set to either "CONFIDENTIAL" or "PRIVATE" are treated in the same way by the server and are imported as "private" appointments
  • Since "private" appointments with participants are not supported by the server, saving such an appointment results in the participants being removed implicitly during import.

Debug Options

In case of synchronization problems, the built-in error console of Mozilla Thunderbird may provide valuable information. The error console can be opened via "Tools" -> "Error Console". To increase the loglevel of the Lightning Add-on, open the config editor by selecting "Tools" -> "Options..." -> "Advanced" -> "Config Editor..." and set the properties "calendar.debug.log" and "calendar.debug.log.verbose" to "true".