Difference between revisions of "AppSuite:DocumentConverterInstall"

(remove old repo description)
m
 
(5 intermediate revisions by the same user not shown)
Line 5: Line 5:
 
See [[AppSuite:ReaderEngineInstall|Readerengine installation instructions]] for details on the setup of the underlying readerengine.
 
See [[AppSuite:ReaderEngineInstall|Readerengine installation instructions]] for details on the setup of the underlying readerengine.
  
For a more detailed guide explaining different installation variants, inluding details on installing Document Converter Client in various configurations, visit the [[AppSuite:DocumentConverter_Installation_Guide|Installation Guide]]. The client is required in order to preview documents.
+
For a more detailed guide explaining different installation variants, inluding details on installing Document Converter Client in various configurations, visit the [[AppSuite:DocumentConverter_Installation_Guide|Installation Guide]]. The client is required in order to use [[AppSuite:DocumentViewer|Preview functionality]].
  
Instructions for manual steps needed for the [[AppSuite:DocumentConverterUpdate782|Update to 7.8.2]] from earlier versions.
+
The Document Converter is installed according to the following instructions.
 
+
From version 7.10.2-rev5 on DocumentConverter can support preview functionality in OX App Suite 7.6.3, 7.8.4 and 7.10.x.
The Document Converter is installed according to the following instructions.
 
  
 
=== Redhat Enterprise Linux 6 or CentOS 6 ===
 
=== Redhat Enterprise Linux 6 or CentOS 6 ===
Line 57: Line 56:
 
  $ zypper install readerengine open-xchange-documentconverter  
 
  $ zypper install readerengine open-xchange-documentconverter  
  
== end ==
 
 
{{InstallPlugin|pluginname=open-xchange-documentconverter-server|toplevel=products|sopath=appsuite/stable/documentconverter|version=App Suite|reponame=documentconverter|ldbaccount=CUSTOMERID:PASSWORD}}
 
 
You also have to add the update repository:
 
 
{{InstallPlugin|pluginname=open-xchange-documentconverter-server|toplevel=components|sopath=documentconverter/updates/7.8.4|version=App Suite|reponame=documentconverter|ldbaccount=CUSTOMERID:PASSWORD}}
 
 
== old content end ==
 
  
 
[[Category:AppSuite]]
 
[[Category:AppSuite]]
 
[[Category:Administrator]]
 
[[Category:Administrator]]

Latest revision as of 09:34, 25 October 2019

Description

This is the Open-Xchange implementation of the Document Converter API. While the API is open, the implementation is not licensed under GPL. It maintains the running instances of readerengines, which are headless OpenOffice instances. This behavior can be configured through documenterconverter.properties configuration file. The Document Converter is only available via a valid Open-Xchange license key.

See Readerengine installation instructions for details on the setup of the underlying readerengine.

For a more detailed guide explaining different installation variants, inluding details on installing Document Converter Client in various configurations, visit the Installation Guide. The client is required in order to use Preview functionality.

The Document Converter is installed according to the following instructions. From version 7.10.2-rev5 on DocumentConverter can support preview functionality in OX App Suite 7.6.3, 7.8.4 and 7.10.x.

Redhat Enterprise Linux 6 or CentOS 6

Add the following repositories to your Open-Xchange yum configuration:

 [open-xchange-backend]
name=Open-Xchange-backend
baseurl=https://software.open-xchange.com/products/appsuite/stable/backend/RHEL6/
gpgkey=https://software.open-xchange.com/oxbuildkey.pub
enabled=1
gpgcheck=1
metadata_expire=0m

[open-xchange-documentconverter-api] name=Open-Xchange-documentconverter-api baseurl=https://software.open-xchange.com/products/appsuite/stable/documentconverter-api/RHEL6/ gpgkey=https://software.open-xchange.com/oxbuildkey.pub enabled=1 gpgcheck=1 metadata_expire=0m
[open-xchange-pdftool] name=Open-Xchange-pdftool baseurl=https://software.open-xchange.com/products/appsuite/stable/pdftool/RHEL6/ gpgkey=https://software.open-xchange.com/oxbuildkey.pub enabled=1 gpgcheck=1 metadata_expire=0m
[open-xchange-documentconverter] name=Open-Xchange-documentconverter baseurl=https://[CUSTOMERID:PASSWORD]@software.open-xchange.com/products/appsuite/stable/documentconverter/RHEL6/ gpgkey=https://software.open-xchange.com/oxbuildkey.pub enabled=1 gpgcheck=1 metadata_expire=0m
[open-xchange-readerengine] name=Open-Xchange-readerengine baseurl=https://[CUSTOMERID:PASSWORD]@software.open-xchange.com/products/appsuite/stable/readerengine/RHEL6/ gpgkey=https://software.open-xchange.com/oxbuildkey.pub enabled=1 gpgcheck=1 metadata_expire=0m
$ yum install readerengine open-xchange-documentconverter

Redhat Enterprise Linux 7 or CentOS 7

Add the following repositories to your Open-Xchange yum configuration:

 [open-xchange-backend]
name=Open-Xchange-backend
baseurl=https://software.open-xchange.com/products/appsuite/stable/backend/RHEL7/
gpgkey=https://software.open-xchange.com/oxbuildkey.pub
enabled=1
gpgcheck=1
metadata_expire=0m

[open-xchange-documentconverter-api] name=Open-Xchange-documentconverter-api baseurl=https://software.open-xchange.com/products/appsuite/stable/documentconverter-api/RHEL7/ gpgkey=https://software.open-xchange.com/oxbuildkey.pub enabled=1 gpgcheck=1 metadata_expire=0m
[open-xchange-pdftool] name=Open-Xchange-pdftool baseurl=https://software.open-xchange.com/products/appsuite/stable/pdftool/RHEL7/ gpgkey=https://software.open-xchange.com/oxbuildkey.pub enabled=1 gpgcheck=1 metadata_expire=0m
[open-xchange-documentconverter] name=Open-Xchange-documentconverter baseurl=https://[CUSTOMERID:PASSWORD]@software.open-xchange.com/products/appsuite/stable/documentconverter/RHEL7/ gpgkey=https://software.open-xchange.com/oxbuildkey.pub enabled=1 gpgcheck=1 metadata_expire=0m
[open-xchange-readerengine] name=Open-Xchange-readerengine baseurl=https://[CUSTOMERID:PASSWORD]@software.open-xchange.com/products/appsuite/stable/readerengine/RHEL7/ gpgkey=https://software.open-xchange.com/oxbuildkey.pub enabled=1 gpgcheck=1 metadata_expire=0m
$ yum install readerengine open-xchange-documentconverter

Debian GNU/Linux 8.0 (Jessie)

Add the following repositories to your Open-Xchange apt configuration:

deb https://software.open-xchange.com/products/appsuite/7.8.4/backend/DebianJessie /
deb https://software.open-xchange.com/products/appsuite/7.8.4/documentconverter-api/DebianJessie /
deb https://software.open-xchange.com/products/appsuite/7.8.4/pdftool/DebianJessie /
deb https://[CUSTOMERID:PASSWORD]@software.open-xchange.com/products/appsuite/7.8.4/documentconverter/DebianJessie /
deb https://[CUSTOMERID:PASSWORD]@software.open-xchange.com/products/appsuite/7.8.4/readerengine/DebianJessie /
$ apt-get update
$ apt-get install readerengine open-xchange-documentconverter

Debian GNU/Linux 9.0 (Stretch)

Add the following repositories to your Open-Xchange apt configuration:

deb https://software.open-xchange.com/products/appsuite/stable/backend/DebianStretch /
deb https://software.open-xchange.com/products/appsuite/stable/documentconverter-api/DebianStretch /
deb https://software.open-xchange.com/products/appsuite/stable/pdftool/DebianStretch /
deb https://[CUSTOMERID:PASSWORD]@software.open-xchange.com/products/appsuite/stable/documentconverter/DebianStretch /
deb https://[CUSTOMERID:PASSWORD]@software.open-xchange.com/products/appsuite/stable/readerengine/DebianStretch /
$ apt-get update
$ apt-get install readerengine open-xchange-documentconverter

SUSE Linux Enterprise Server 12

$ zypper ar https://software.open-xchange.com/products/appsuite/stable/backend/SLE_12 backend
$ zypper ar https://software.open-xchange.com/products/appsuite/stable/documentconverter-api/SLE_12 documentconverter-api
$ zypper ar https://software.open-xchange.com/products/appsuite/stable/pdftool/SLE_12 pdftool
$ zypper ar https://[CUSTOMERID:PASSWORD]@software.open-xchange.com/products/appsuite/stable/documentconverter/SLE_12 documentconverter
$ zypper ar https://[CUSTOMERID:PASSWORD]@software.open-xchange.com/products/appsuite/stable/readerengine/SLE_12 readerengine
$ zypper ref
$ zypper install readerengine open-xchange-documentconverter